Repository navigation
Python: Update flit-core requirement from <4.0,>=3.9 to >=3.9,<5.0 in /python - #14596
dependabot[bot] wants to merge 1 commit into
Conversation
Updates the requirements on [flit-core](https://github.com/pypa/flit) to permit the latest version. - [Changelog](https://github.com/pypa/flit/blob/main/doc/history.rst) - [Commits](pypa/flit@3.9.0...4.1.0) --- updated-dependencies: - dependency-name: flit-core dependency-version: 4.1.0 dependency-type: direct:development ... Signed-off-by: dependabot[bot] <support@github.com>
There was a problem hiding this comment.
🟢 Approval recommended
The project uses compatible PEP 621 metadata and the dependency constraint update is valid.
0 open findings
What changed in this PR
Updates the Python package build backend constraint to permit Flit Core 4.x.
Changes:
- Expands the supported
flit-corerange from<4.0to<5.0.
| File | Description |
|---|---|
python/pyproject.toml |
Allows Flit Core 4.x for Python package builds. |
🧠 Review effort: Balanced
💡 Add a code-review agent skill or configure MCP servers for context-aware, tailored reviews. Learn more in the docs.
|
OK, I won't notify you again about this release, but will get in touch when a new version is available. If you'd rather skip all updates until the next major or minor version, let me know by commenting If you change your mind, just re-open this PR and I'll resolve any conflicts on it. |
Updates the requirements on flit-core to permit the latest version.
Changelog
Sourced from flit-core's changelog.
... (truncated)
Commits
75b1c90Merge pull request #826 from pypa/prepare-4.1b5ad0d7Add release note about PR #8249fb48c1Bump version: 4.0.2 → 4.1.0a4ea331Prepare release notes for 4.1337c499Merge pull request #824 from r3wretrhy/fix-win-cmd-crlf04cfa08Merge pull request #825 from hxperl/docs-dynamic-fields33be607doc: list all four fields accepted in project.dynamicd538cb4install: keep explicit CRLF in Windows .cmd wrappers3c92604Merge pull request #809 from yangfan-yf-yf/fix/spdx-with-exceptions33a7a39Clarify SPDX WITH version requirement and error messageDependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting
@dependabot rebase.Dependabot commands and options
You can trigger Dependabot actions by commenting on this PR:
@dependabot rebasewill rebase this PR@dependabot recreatewill recreate this PR, overwriting any edits that have been made to it@dependabot show <dependency name> ignore conditionswill show all of the ignore conditions of the specified dependency@dependabot ignore this major versionwill close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)@dependabot ignore this minor versionwill close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)@dependabot ignore this dependencywill close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)